taniabelkova
20.11.2021 11:26

> > составить программу на паскале. < < сформировать двухмерный массив a[1..10,1..10] случайными значениями в диапазоне [0..20]. создать одномерный массив b[1..10], значения элементов которого равны сумме элементов строк двухмерного массива. массив b вывести на экран. p.s: без наворочек, тип циклы, условия если надо и сами массивы. : c

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
qqqqq9
07.10.2020 03:20
Const n=10;
var 
a:array[1..n,1..n] of integer;
b:array[1..n] of integer;
i,j,s:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to n do
  begin
  a[i,j]:=random(21);
  write(a[i,j]:4);
  end;
  writeln;
 end;
for i:=1 to n do
 begin
 s:=0;
 for j:=1 to n do s:=s+a[i,j];
 b[i]:=s;
 end;
writeln('Полученный массив:');
for i:=1 to n do write(b[i]:4);
writeln; 
end.

Пример:
Исходный массив:
   8  12  16  16  19  15  11  11  13   7
   7   3  20   3  13   2  20  18   9   2
  18  11  17   0   4   0  18   3  17  12
  12   9  18   9  18   4   7  15   4  20
  17  12  13  20  12  20   4  10  16  18
  15  19   2   1  18  20  13   1  19   3
  12   7   8  13   3   3  15  13   2  15
  15   0  20   9  20  14   3  19   6  20
  12   4  19   0  19   2  18   4  12  10
   3   7   5  15  15   3  19   9  10   8
Полученный массив:
 128  97 100 116 142 111  91 126 100  94
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота