KLIN50
12.05.2021 03:16

Выяснить, ли цифры в записи числа по убыванию. написать программу в pascalabc.net и нарисовать блок-схему.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kamila0277
07.10.2020 02:52
Var
  n: integer;
  a, b: byte;

begin
  read(n);
  b := n mod 10;
  n := n div 10;
  a := n mod 10;
  n := n div 10;
  while (a > b) and (n <> 0) do
  begin
    b := a;
    a := n mod 10;
    n := n div 10;
  end;
  if a > b then
    writeln('Цифры числа расположены по убыванию')
  else
    writeln('Цифры числа расположены не по убыванию')
end.
0,0(0 оценок)
Ответ:
keniwo
07.10.2020 02:52
Vara,b,i,k,max:integer;beginreadln(a);max:=0;k:=0;while a<>1 do begin
if (a mod 10) > max then beginmax:=(a mod 10);endelse k+=1;
a:=a div 10;if a<10 then begin  if (a mod 10) > max then beginmax:=(a mod 10);endelse k+=1;a:=1;
end;end;if k=0 then writeln('Убывание') else writeln('Неубывание');end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота