mashaa2660
23.07.2021 23:20

Напишите программу которая сравнивает три числа и выводит произведение двух наименьших

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
shenjaaoy169t
07.10.2020 02:09
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
int GetMin(vector<int> arr, int &index)
{
  int min = arr[0];
  index = 0;
  for (int i = 0; i < arr.size(); i++)
  {
    if (arr[i] < min)
    {
      index = i;
    }
  }
  return arr[index];
}
int main()
{
  vector<int> n;
  n.resize(3);
  cin >> n[0] >> n[1] >> n[2];
  int i = 0;
  int min1 = GetMin(n, i);
  n.erase(n.begin() + i);
  int min2 = GetMin(n, i);
  cout << min1 * min2;
  cin >> n[0];
  return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота