ФелаБульф12
12.12.2022 19:14

Написать программу, которая вводит с клавиатуры последовательность из 5-ти вещественных чисел и после ввода каждого числа выводит среднее арифметическое полученной части последовательности на паскале (через for to do)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
64681
07.10.2020 01:16
Var a,s:real; i:integer;
begin
s:=0;
for i:=1 to 5 do
 begin
 readln(a);
 s:=s+a;
 writeln(s/i:5:2);
 end;
end.

Пример:
2.8
 2.80
9.4
 6.10
0.7
 4.30
6.0
 4.72
4.1
 4.60
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота