kutinaI
24.01.2020 21:23

Написать программу в паскале. ввести с клавиатуры 6 произвольных чисел. вычислить среднее арифметическое тех чисел, которые делятся на 4 и заканчиваются на 5.( остаток на деление на 10 равен 5).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
PechenkO629
07.10.2020 01:02
Var i, x, count: integer;
    sum: real;

begin
    sum := 0;
    count := 0;
    for i := 1 to 6 do
        begin;
        writeln('Введите число');
        readln(x);
        if (x mod 4 = 0) or (x mod 10 = 5) then
            begin;
            sum := sum + x;
            count := count + 1;
            end;
        end;
    writeln(sum/count);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота