yaroslavgolova
21.05.2020 01:39

Паскаль составить программу отсортировать 4 столбец двумерного массива по возрастанию (8 на 8)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Катя7544
03.08.2020 21:29
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(8,8,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  a.SetCol(3,a.Col(3).OrderBy(x->x).ToArray);
  Writeln('*** Полученный массив ***'); a.Println(4)
end.

Пример
*** Исходный массив ***
  77  68  79 -85  30 -28 -11  85
 -52 -62 -94 -30 -82  31 -16 -80
 -97 -95  84 -62 -53   5  68 -23
  53   7  38  10 -88 -66  98  85
 -99 -31  -6  71  32  -2  84 -87
  45  46 -35  -2 -97 -46 -76 -66
 -18 -10  72 -95  73 -55  -7 -27
  99   3 -39 -77  33  78  73 -85

*** Полученный массив ***
  77  68  79 -95  30 -28 -11  85
 -52 -62 -94 -85 -82  31 -16 -80
 -97 -95  84 -77 -53   5  68 -23
  53   7  38 -62 -88 -66  98  85
 -99 -31  -6 -30  32  -2  84 -87
  45  46 -35  -2 -97 -46 -76 -66
 -18 -10  72  10  73 -55  -7 -27
  99   3 -39  71  33  78  73 -85
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота