vddrobysheva
10.02.2023 05:10

Даны три целых числа.напишите программу ,подсчитывающую сумму тех чисел ,которые являются нечетными

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Котик132457
06.10.2020 23:17
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadInteger3('Введите три целых числа:');
  var s:=0;
  if a.IsOdd then s+=a;
  if b.IsOdd then s+=b;
  if c.IsOdd then s+=c;
  Writeln('сумма нечетных равна ',s)
end.

Пример
Введите три целых числа: 345423 -324342 1231
сумма нечетных равна 346654
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота