Войти
Регистрация
Спроси ai-bota
L1mbada
12.10.2021 12:42
Все богом молю написать программу на языке с дано число x. напечатать в порядке возрастания ln(x), 1+|x|, (1+x^2) x p s только не надо как обычно бред писать ради
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Serlous
09.09.2020 00:55
Як розв язують задачі засобами таличого процесора...
vlad97vb
07.09.2022 05:37
Найдите сдесь ошибку и напишите в исправном виде учитель сказал что там ошибка есть var j,i,min,k,t: integer; a: array [1..100] of integer; begin a[1]: =5; a[2]: =4;...
annakara0491
27.01.2020 01:27
Уисполнителя калькулятор две команды,которым присвоена номера: 1. прибавь 2 2. умножь на 2. сколько есть программ,которые число 1 преобразуют в число 24?...
parknariya
22.02.2023 19:16
Исправьте программу и протестируйте ееПаскаль...
sentyakovv
12.05.2023 05:29
1. Введите Х. Вычислите У по формуле У=2,7*х3+0,23*х2-1,4 2. Введите вес в кг. Переведите его в фунты. 1 фунт=409,5 граммов 3. Проверка введённого числа на четность 4....
vorobeowmikhai
26.07.2020 07:14
решить информатика 9 класса...
MrMixa008
29.10.2022 08:42
Решите задачи Формулу распишите еще...
овшаь
26.12.2022 16:25
Дано двузначное число. найти модуль разности его цифр. по паскалю напишите решение....
Новичок301117
26.12.2022 16:25
Какое число больше ? а)1527 ; б) 15210 ; в) 15212; г) 15216. решите уравнение: 11102+? =1110012....
1111Кристина11111
30.08.2022 08:54
Только не с интернета) в школьную команду по волейболу было отобрано некоторое количество учеников из 64 претендентов. сколько учеников было отобрано, если сообщение...
Ответ:
Darina2581
20.08.2020 22:58
#include <stdio.h>
#include <math.h>
int main()
{
float x, y1, y2, y3;
scanf("%f",&x);
y1 = log(x);
printf("Ln(x) = %f\n", y1);
y2 = 1+fabs(x);
printf("1+|x| = %f\n", y2);
y3 = (1+x*x)*x;
printf("(1+x^2)*x = %f\n", y3);
if ((y1<y2)&&(y1<y3)) {
if (y2<y3) printf("%f %f %f", y1,y2,y3);
else printf("%f %f %f", y1,y3,y2);
}
else if ((y2<y1)&&(y2<y3)) {
if (y1<y3) printf("%f %f %f", y2,y1,y3);
else printf("%f %f %f", y2,y3,y1);
}
else if (y1<y2) printf("%f %f %f", y3,y1,y2);
else printf("%f %f %f", y3,y2,y1);
return 0;
}
Пример:
0.8
Ln(x) = -0.223144
1+|x| = 1.800000
(1+x^2)*x = 1.312000
-0.223144 1.312000 1.800000
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота