4ex9s
10.05.2022 03:37

Дан массив из 13 элементов. элементами массива являются первые 13 нечетных чисел. найти произведение элементов этого массива. написать программу в паскале, как можно проще, без лишних наворотов, .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
123456на
06.10.2020 21:35
Var   proizv:int64; 
  a: array [1..13] of integer;
begin
  // заполняем массив
  for var i:=1 to 13 do
    a[i]:=i+i-1;
  proizv:=1;
  // основной цикл
  for var i:=1 to 13 do
    proizv:=proizv*a[i];
  writeln('Произведение = ',proizv);
end.

Это работает в АБС-паскале
Типа данных integer мало для хранения произведения, но int64 - достаточно
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота