znanija140
11.11.2020 10:43

Язык c++.задано натуральное число n. напишите программу, которая определяет количество натуральных чисел, не больше n и не делятся ни на одно из чисел 2, 3, 5. входные данные: число n (1 ≤ n ≤ 1000000000). выходные данные: найденное число пример input output 10 2 обратите внимание на то что программа проверяется компилятором ,и он не должен показывать ошибки.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Danilos01
06.10.2020 21:24
#include <iostream>
using namespace std;

int main()
{
    int n;
    int k=0;
    cout << "n = ", cin >> n, cout << "\n";
    for (int i=1; i<=n; i++) {
    if ((i%2 != 0)&&(i%3 != 0)&&(i%5 != 0)) k++;
    }
    cout << k << "\n";
    return 0;
}

Пример:
n = 10
2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота