mytaevafati
05.09.2022 12:23

Написать программу в pascal даны целые числа . если в данной последовательности ни одно четное число не расположено после нечетного.то получить все отрицательные члены последовательности иначе-положительное.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MrDackes
24.05.2020 00:41

var
a: array[1..50] of integer;
i,f, n: integer;

begin
write('n=');
readln(n);
for i := 1 to n do
begin
write('a', i, '=');
readln(a[i]);
end;
f := 0;
writeln;
for i := 1 to n - 1 do
if (a[i] mod 2 <> 0) and (a[i + 1] mod 2 = 0) then f := 1;
if f = 0 then
begin
for i := 1 to n do
if a[i] < 0 then write(a[i]:4);
end
else
for i := 1 to n do
if a[i] > 0 then write(a[i]:4);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота