volkovaw
03.08.2022 18:37

Язык c#. написать программу на языке c#разветвляющейся структуры согласно вариантам 1 (используя if) и 2 (используя switch) . 1.даны два числа. большее из этих двух чисел заменить их полусуммой, а меньшее удвоенным произведением. 2.2. вводится число экзаменов n< =20. напечатать фразу "мы успешно сдали n экзаменов", согласовав слово "экзамен" с числом n.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
AndreySolmikov
06.10.2020 21:03
1.
using System;

class Program
{
public static void Main()
{
         double x,y,s,p;
         Console.Write("x = ");
         x = double.Parse(Console.ReadLine());
         Console.Write("y = ");
         y = double.Parse(Console.ReadLine());
         s = (x+y)/2;
         p = 2*x*y;
         if (x>y){
          x = p;
          y = s;
         }
         else {
          y = p;
          x = s;
         }
        Console.WriteLine("x = {0}, y = {1}", x, y);
        Console.ReadKey();
}
}

Пример:
x = 2.4
y = 8.3
x = 5.35, y = 39.84

2.
using System;

public class Test
{
public static void Main()
{
int n;
Console.Write("n = ");
n = int.Parse(Console.ReadLine());
switch (n){
case 1:
Console.WriteLine("Мы успешно сдали {0} экзамен", n);
break;
case 2:
case 3:
case 4:
Console.WriteLine("Мы успешно сдали {0} экзамена", n);
break;
default:
Console.WriteLine("Мы успешно сдали {0} экзаменов", n);
break;
}
}
}

Пример:
n = 6
Мы успешно сдали 6 экзаменов
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота