dreakalex
11.04.2021 08:05

Решето эратосфена в pascalabc данные вводятся с клавиатуры или из файла input.txt, выводятся на экран или в файл output.txt. первые тесты не всегда с примерами из условия. напишите программу, которая выводит все простые числа в диапазоне от 2 до n включительно ( 2 ≤ n ≤ 100000 ). входные данные входная строка содержит целое число n ( 2 ≤ n ≤ 100000 ). выходные данные программа должна вывести все простые числа в диапазоне от 2 до n в одну строку, разделив их пробелами. примеры входные данные : 20 выходные данные : 2 3 5 7 11 13 17 19

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
solnechnaya2
06.10.2020 20:40
Program n1;
var n,i: longint;
function simply(a: longint ):boolean;
var i: longint;
begin
simply:=true;
for i:=2 to trunc(sqrt(a)) do begin if a mod i=0 then begin
simply:=false;
break
end
end
end;
begin
readln(n);
for i:=2 to n do if simply(i) then write(i,' ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота