silchuk2004
02.06.2020 21:57

Задано двухзначное число. составить программу, которая отвечает на вопрос, правда ли, что все его цифры чётные

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Викасичек
06.10.2020 20:30
// PascalABC.NET 3.3, сборка 1540 от 16.09.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Введите двухзначное натуральное число:');
  if (n div 10).IsEven and (n mod 10).IsEven then Writeln('Да')
  else Writeln('Нет')
end.

Пример
Введите двухзначное натуральное число: 28
Да
0,0(0 оценок)
Ответ:
Whitecat111
06.10.2020 20:30
Program oddn;
var
a,b,c: integer;

begin
readln(c);
a:=c div 10;
b:=c - a*10;
if (a and 1=0) and (b and 1=0) then
writeln('все цифры четные')
else
writeln('есть нечетные цифры');

end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота