alekcandrina200
07.12.2021 06:08

Напишите программу на языке си. дан текст произвольной длины оканчивающийся точкой c запятой. подсчитать количество “: =” в тексте

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yuri520
06.10.2020 13:59
#include <stdio.h>

int main(void) {
char c1,c2;
int k=0;
printf("Вводите символы (в конце ';')\n");
scanf("%c",&c2);
do {
c1 = c2;
scanf("%c",&c2);
if ((c1 == ':')&&(c2 == '=')) k++;
}
while (c2 != ';');
printf("k = %d",k);
return 0;
}

Пример:
Вводите символы (в конце ';') 
i:=0, s:=0;
k = 2
0,0(0 оценок)
Ответ:
Сchernyh
06.10.2020 13:59
:=;"
  int
    i = 1,
    cnt = 0;

  if (str[0] == ';')
    return;
  
  while (str[i] != ';')
  {
    if (str[i - 1] == ':' && str[i] == '=')      cnt++;    i++;  }

  printf("%i\n", cnt);
  _getch();
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота