Написать программу, язык pascal. ввести целое положительное число трехзначное число n. разбить это число на разряды (найти число сотен, десятков и единиц). найти сумму разрядов числа n
Program razrad; var n,a,b,c,s: integer; begin write('введите положительное трехзначное число - '); readln(n); a:=n mod 10; {последняя цифра} b:=(n div 10) mod 10; {средняя цифра} c:=n div 100; {первая цифра} writeln('сотен - ', с, ', десятков -',b,', единиц - ',a); s:=a +b+c: writeln('сумма цифр числа - ',s) end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку