Misha31071986
18.08.2020 21:51

Составить составить программу на pascal! : вычислить 

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
0502abylai
06.10.2020 13:48
Если (n - 1)-ое слагаемое равно y, то n-ое слагаемое равно -y * x^2 / (2n * (2n + 1)). Осталось положить первое слагаемое равным x и просуммировать 6 раз.

PascalABC.NET 3.2
begin
  var x := readReal;
  var y := x;
  var s := x;
  var n := 1;
  while (n < 7) do
  begin
    y := -y * x * x / (2 * n) / (2 * n + 1);
    s += y;
    n += 1;
  end;
  writeln(s);
end.

Пример ввода: 1
Пример вывода: 0.841470984808658
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота