MYLITTLEPONY15
15.05.2022 22:35

Язык си написать программу,которая находит количество простых членов последовательности.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
милка578
06.10.2020 13:37
#include<iostream>
#include<cmath>
using namespace std;

int main()
{
    setlocale(LC_ALL,"RUS");
    int N;
    cout <<"Введите количество чисел: ",cin >> N;
    cout <<"Введите сами числа: ";
    int k = 0;
    for(int i = 0; i < N; i++)
    {
        int A;
        cin >> A;
        if (A > 3)
        {
            int B = 1, K = sqrt(A), d = 2;
            while(d <= K)
            {
                if (A % d++ == 0)
                {
                    B = 0;
                    break;
                }
            }
            if (B) k++;
        }
        else if (A > 1) k++;
    }
    cout <<"Количество простых, среди введённых: "<<k;
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота