Войти
Регистрация
Спроси ai-bota
yuuliiya1717
26.04.2021 04:30
Написать программу на с++ надо вывести из строки со словами разделенными пробелами , вывести слова в которых буквы не повторяются
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
TuplinaTina
14.02.2020 16:31
3) Начертить общий вид блок-схемы цикла с постусловием. II) Pascal 4) Написать команду цикла с условием (в языке Pascal) полностью (общий вид). 5) Исправить все ошибки...
ндо
14.10.2020 19:45
Напишите программу(на си шарпе), которая рассчитывает значение y при заданном значении x: 0,при х =0 y=фx,при 0 x в 4 степени,при х =0...
lubivyjn
31.10.2020 19:41
II вариант1. Назначение MSExcel:1) проведение расчётов;2) проведение расчётов, решение задач оптимизации;3) проведение расчетов, решение задач оптимизации, построение...
Valeriyanka2001
22.02.2020 01:13
Заготовка майбутнього документа, що містить різні об єкти називається...
oksanayarockay
27.10.2020 03:58
Создайте файл с информацией о вакансиях в поезде. структура записи: дата вылета, номер рейса, последний пункт назначения, время вылета, количество свободных мест в...
Alisa11221122
03.05.2022 09:57
В кодировке КОИ-8 каждый символ кодируется 8 битами. Вова написал текст (в нём нет лишних пробелов):«Личи, гуава, дуриан, кумкват, тамаринд, мангустин, джаботикаба...
fhchfyhf1
06.03.2023 22:50
Paskal напишите программу ...
valeriyait
28.11.2020 11:50
Раскрась бусины в цепочке р по инструкции: 1. квадратную бусину раскрась красным . 2. четвертую бусину после красной квадратной раскрась синим. 3. пятую бусину перед...
qRinaTeinaq
28.11.2020 11:50
Вводится n строка, найти кол-во пробелов в ней. pascal abc...
Fluttershy0
04.06.2020 20:08
Устройство ввода, прямое название которого ввод символьной информации,- а)мышь б)тачпад в)джойстик г)клавиатура...
Ответ:
всёокок
06.10.2020 13:35
#include<iostream>
#include<string>
using namespace std;
int main()
{
string S;
cout << "BBEDITE TEXT: ", getline(cin,S);
S+=' ';
string Slovo = "";
for (int i = 0; i < S.length(); i++)
{
if (S[i] != ' ') Slovo+=S[i];
else
{
bool B = 1;
for(int j = 0; j+1 < Slovo.length(); j++)
{
for(int m = j+1; m < Slovo.length(); m++)
{
if (Slovo[j] == Slovo[m]) B = 0;
}
}
if (B) cout<<"\n" <<Slovo;
while (S[i] == ' ') i++;
Slovo=S[i];
}
}
return 0;
}
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота