Churekkey
18.01.2020 11:39

Составить программу - тест, которая запрашивает имя и предлагает ответить на три вопроса. отвечать можно "да" или "нет". при вводе другого ответа - возврат к вопросу. в итоге программа выдает количество верных ответо

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nissanbaev25
06.10.2020 13:32
Var
   O:string;
   i,k:byte;
   B,pO:array[1..3] of string;
Begin
B[1]:='2 * 2 = 5 ?';pO[1]:='нет';
B[2]:='Оператор Read вводит данные?';pO[2]:='да';
B[3]:='СССР победил в войне 1812 года?';pO[3]:='нет';
k:=0;
For i:= 1 to 3 do
    Begin
    WriteLn(B[i]);
    ReadLn(O);
    O:=LowerCase(O);
    While (O <> 'да')and(O <> 'нет') do
       Begin
       Write('Попробуйте ещё раз: ');ReadLn(O);
       O:=LowerCase(O);
       End;
    if pO[i] = O then k:=k+1;
    End;
WriteLn('Количество правильных ответов: ',k);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота