tiMYPkomptik
16.10.2021 18:57

Составить программу для вычисления значений функции f(x) на отрезке [а, ь] с шагом h. результат представить в виде таблицы, первый столбец которой — значения аргумента, второй — соответствующие значения функции. f(x) = 2sin^2(квадрат)x+1;

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
1mironov1
06.10.2020 13:28
Var
  a,b,h,x,y:real;
label M;
begin
  Write('Введите a,b,h :');
  Read(a,b,h);
  x:=a;
M:
  if x<=b+h/2 then begin
    y:=2*Sqr(Sin(x))+1;
    Writeln(x:12:7,y:18:7);
    x:=x+h;
    goto M
    end
end.

Пример
Введите a,b,h :-5 4 0.2
  -5.0000000         2.8390715
  -4.8000000         2.9846879
  -4.6000000         2.9748436
  -4.4000000         2.8110930
  -4.2000000         2.5192887
  -4.0000000         2.1455000
  -3.8000000         1.7487402
  -3.6000000         1.3916487
  -3.4000000         1.1306025
  -3.2000000         1.0068151
  -3.0000000         1.0398297
  -2.8000000         1.2244341
  -2.6000000         1.5314833
  -2.4000000         1.9125010
  -2.2000000         2.3073329
  -2.0000000         2.6536436
  -1.8000000         2.8967584
  -1.6000000         2.9982948
  -1.4000000         2.9422223
  -1.2000000         2.7373937
  -1.0000000         2.4161468
  -0.8000000         2.0291995
  -0.6000000         1.6376422
  -0.4000000         1.3032933
  -0.2000000         1.0789390
   0.0000000         1.0000000
   0.2000000         1.0789390
   0.4000000         1.3032933
   0.6000000         1.6376422
   0.8000000         2.0291995
   1.0000000         2.4161468
   1.2000000         2.7373937
   1.4000000         2.9422223
   1.6000000         2.9982948
   1.8000000         2.8967584
   2.0000000         2.6536436
   2.2000000         2.3073329
   2.4000000         1.9125010
   2.6000000         1.5314833
   2.8000000         1.2244341
   3.0000000         1.0398297
   3.2000000         1.0068151
   3.4000000         1.1306025
   3.6000000         1.3916487
   3.8000000         1.7487402
   4.0000000         2.1455000
0,0(0 оценок)
Ответ:
волна16
06.10.2020 13:28
Uses Crt;
Var a,b,h:real;
Begin
ClrScr;
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('h = ');ReadLn(h);
Repeat
WriteLn('F(',a,') = ',2*Sqr(Sin(a))+1);
a:=a+h;
Until a > b;
ReadKey
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота