Написать программу в паскале. дано натуральное семизначное число р. вывести на экран цифры чила, которые делятся на а без остатка. определить кол-во цифр, удовлетворяющих этому условию.
// PascalABC.NET 3.2, сборка 1467 от 02.06.2017 // Внимание! Если программа не работает, обновите версию!
begin Write('Введите Р и а: '); var (P,a):=ReadInteger2; var k:=0; while P>0 do begin var d:=P mod 10; if d mod a=0 then begin Print(d); k+=1 end; P:=P div 10 end; Writeln(Newline,'Искомых чисел: ',k) end.
Пример Введите Р и а: 7568450 5 0 5 5 Искомых чисел: 3
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку