MrAmoral
10.06.2020 06:49

Написать программу, которая запрашивает имя файла и распечатывает из него только те строки, которые являются палиндромами(python)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MalichikSpodezga
06.10.2020 13:10
Python 2.7
def main('__init__')
    text=read(file)
    for i in strings(text)
        if i is i.palyndrome()
            print(i)
0,0(0 оценок)
Ответ:
аня2940
06.10.2020 13:10
# Python 3.6.1

print("Введите имя файла: ",end='')
f = open(input())
for S in f:
   if S[-1] == '\n':
      S = S[:-1]
   L = len(S)
   B = 1
   for i in range(L//2):
      if S[i] != S[L-i-1]: B = 0
   if B == 1:
      print(S)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота