17834567
29.08.2021 07:22

Имя для питона питоны внимательно относятся к выбору своих имён. сначала для каждого детёныша его мать придумывает последовательность маленьких латинских букв по известному только питонам правилу. однако в результате часто получается труднопроизносимое слово. поэтому в полученной последовательности труднопроизносимые буквы нужно заменить на любимую питонами букву a. но это не всегда возможно, так как древний питонский закон гласит, что нельзя менять буквы, стоящие на позициях ci (по древней традиции, позиции нумеруются, начиная с нуля). входные данные в первой строке записано слово s (1 ≤ len(s) ≤ 100), придуманное матерью питона и состоящее из маленьких латинских букв. во второй строке через пробел перечислены буквы bi(1 ≤ i ≤ 25), труднопроизносимые для питонов. в третьей строке через пробел перечислены позиции ci (0 ≤ ci < len(s), 0 ≤ i ≤ len(s) ≤ 100), изменения в которых запрещены древним законом. в последней строке находится любимая питонами буква a (a ≠ bi) при любом i). выходные данные выведите одну строку – результирующее имя питона. входные данные sample 1 james m r t e s sample 2 niishka k i 1 2 h выходные данные sample 1 jasss sample 2 niishha

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nikitoschenko
06.10.2020 13:01
# Python 3.6.1

S = input()
B = input()
C = [int(i) for i in input().split()]
A = input()

for m in [i for i in set([j for j in range(len(S))]).difference(C)]:
   if S[m] in B.split():S =  S[:m] + A[0] + S[m+1:]
print(S)



// Pascal

Var
   S:string[100];
   B:string[50];
   C:array[0..100] of byte;
   A:char;
   j,m:byte;
   L:boolean;
Begin
ReadLn(S);
ReadLn(B);
j:=0;
Read(A);
While A <> #13 do
   Begin
   Read(C[j]);
   C[j]:=C[j]+1;
   j:=j+1;
   Read(A);
   End;
ReadLn();
Read(A);
For m:= 1 to Length(S) do
    Begin
    L:=true;
    For j:= 0 to j do
        if C[j] = m then L:=false;
    if L then
       if pos(S[m],B) <> 0 then S[m]:=A;
    End;
WriteLn(S);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота