98675423
20.04.2020 19:41

Написать программу,которая рассчитывает стоимость со стоимостью скидки 10% в том случае,если сумма покупки больше 1000 рублей и 20%,если cумма покупки больше 5 и 10 000 рублей. ввести стоимость покупки с учетом скидки и без ее учета.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ярик467
06.10.2020 12:18
Var S:real;
Begin
Write('Введите сумму покупки: ');ReadLn(S);
Write('Сумма покупки с учётом скидки: ');
if S <= 1000 then WriteLn(S)
else if S > 10000 then WriteLn(S*0.8:0:2)
     else WriteLn(S*0.9:0:2);
WriteLn('Без учёта скидки: ',S:0:2);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота