Строгая591
05.10.2020 06:17

Склавиатуры вводится n чисел. написать программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введённых чисел. значение n также вводится с клавиатуры. язык с++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
#include<iostream>
using namespace std;

int main()
{
    int n, A, P = 0, O = 0, N = 0;
    cout << "n = ", cin >> n;
    for (int i = 0; i < n; i++)
    {
        cin >> A;
        if (A > 0) P++;
        else if (A < 0) O++;
             else N++;
    }
    cout << "( < 0): " << O;
    cout << "\n( = 0): " << N;
    cout << "\n( > 0): " << P;
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота