Войти
Регистрация
Спроси ai-bota
ФКЗенит1
05.01.2020 06:28
Напишите программу паскаль: с клавиатуры вводится число от 0 до 1000 включительно. каждая цифра не превосходит 6. найти сумму промежуточных значений между наибольшей и наименьшей цифрами в числе?
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
pashnina379
04.08.2022 16:05
Напишите программу по информатике ,на этот пример под корнем 5х-1/ х-10...
петя212
04.08.2022 16:05
Какое количество бит информации несёт сообщение о том что встреча назначена на лето?...
7773530
01.02.2020 12:41
Синформатикойэто программа для лампанели: блок данных программы выглядит так.a: data 1234b: data 4321sum: data 0напишите программу, которая складывает переменные a и b и записывает...
Reizon
27.08.2022 11:00
Напишите программу, которая в последовательнсти целых чисел определяет количество нечетных чисел, кратных 3. программа получает на выход целые числа, количество введенных...
veronikamod
19.12.2022 01:30
Написать циклическое решение уравнения на паскале. 2(cos(x-1)/sin(x-1))^2...
dendemintsev
20.11.2020 15:23
Протабулировать функцию y=sin(2x) на промежутке [-1;1], с шагом h=0,1. Рассчитать среднее арифметическое значений функций больших, чем 0,3 и меньших, чем 0,5. Задание необходимо...
saraarakelyan1
12.05.2022 15:56
.Впишіть назву атрибута, селектор за яким може мати вигляд .main-menu:...
атвсомсча
21.07.2021 21:54
Подготовить на статью на тему интиресные факты об информатике...
fadasgferson
01.03.2022 06:02
Набор команд,которые может выполнять обьект,называют... CРОЧНО ЛСЬАЛСЯ 30 МИНУТ...
samsonovich12S1
14.07.2021 01:56
Социально - развитие после отечественной войны 1812г...
Ответ:
alina28551
16.08.2020 08:01
Попробуй, может сработает)
program num32;var
nums, i, min, max, a, i2, i3, sum: integer;begin
min := 7;
max := 0;
sum := 0;
readln(nums);
while nums <> 0 do
begin
if (((nums mod 10) > max)) then begin
max := nums mod 10;
end;
if (((nums mod 10) < min)) then begin
min := nums mod 10;
end;
nums := nums div 10;
end;
if (min > max) then begin
for i2 := max to min do
sum := sum + i2;
end;
if (max > min) then begin
for i2 := min to max do
sum := sum + i2;
end;
writeln(sum);
end.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота