Neder
03.06.2020 04:07

Напишите программу для вычисления последней ненулевой цифры факториала заданного числа n(0 ≤ n ≤ 10³⁰⁰). циклы использовать запрещено.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vikasibarik
03.08.2020 13:59
Все приведённые ниже коды написаны и отлажены в среде PascalABC.NET 3.2. сборка 1439(10.05.2017).

Сначала программа, показывающая период=))

Var
   N:uint64;
   B:BigInteger:=1;
Begin
Write('N = ');ReadLn(N);
For var i:= 1 to N do
    Begin
    if (i mod 10 <> 5)and(i mod 10 <> 0) then B:=B*i
       else if i mod 10 = 5 then B:=B div 2;
    Write(B mod 10);
    if i mod 40 = 0 then WriteLn;
    End;
End.

N = 1000
1264224288868266264448468868222428448466
6264224288868266264448468868222428448466
6264224288868266264448468868222428448466
6264224288868266264448468868222428448466
6264224288868266264448468868222428448466
6264224288868266264448468868222428448466
6264224288868266264448468868222428448466
6264224288868266264448468868222428448466
6264224288868266264448468868222428448466
6264224288868266264448468868222428448466
6264224288868266264448468868222428448466
6264224288868266264448468868222428448466
6264224288868266264448468868222428448466
6264224288868266264448468868222428448466
...
Ну и так далее.

Искомая программа:

Const
   T = '6626422428886826626444846886822242844846';
Var
   S:BigInteger;
Begin
S:=ReadString.ToBigInteger;
if S > 1 then WriteLn(T[(S mod 40).ToString.ToInteger+1])
else WriteLn(1)
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота