19 ! написать программу для паскаля. с клавиатуры вводятся два натуральных числа (n и m. число n меньшее). вывести на экран все числа от n до m сумма цифр которых равна 12
Var n,m,A,S:integer; Begin Write('n = ');ReadLn(n); Write('m = ');ReadLn(m); For m:= n to m do Begin S:=0; A:=m; While A > 0 do Begin S:=S+A mod 10; A:=A div 10 End; if S = 12 then Write(m,' ') End; End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку