Keyanplay1
02.04.2020 12:02

Дано трехзначное число. составьте программу которая определяет а)кратна ли 5 сумма его первой и последней цифры б) сумма квадратов чисел в диапазоне от 1 до n в) количество натуральных чисел не превышающих 50 и кратных 3

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ALEXFORBIDDEN
06.10.2020 10:37
a)
Program hhh54;
var x: longint;
begin
  read (x);
  if ((x div 100) + (x mod 10)) mod 5 = 0 then write ('КРАТНА')
  else write ('НЕ КРАТНА');
end.
б)
Program hhh54;
var s,n,i: longint;
begin
  s:=0;
  read (n);
  for i:= 1 to n do
    s:=s+sqr(i);
  write (s);
end.
в)
Program hhh54;
var k,n,i: longint;
begin
  k:=0;
  for i:= 1 to 50 do
    if i mod 3 = 0 then k:=k+1;
  write (k);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота