mikrob22
06.10.2020 11:46

Составьте программу вывода на экран всех простых чисел, не превосходящих заданного n. простым называется натуральное число больше единицы, имеющее только два делителя: единицу и само это число

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
duplo214
06.10.2020 09:52
#Python 3.5.2
a = []
n = int(input('Введите n: '))
for i in range (n+1): a.append(0);
for i in range (2, n+1):
    if a[i]==0:
        print (i, end='; ')
        j = 2*i
        while j<=n:
            a[j] = 1
            j+=i
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота