27-я егэшная (c4). проверьте, правильно ли написана программа и является ли она как можно более эффективной по времени и по памяти. для заданной последовательности неотрицательных целых чисел необходимо найти максимальное произведение двух её элементов, номера которых различаются не менее чем на 8. значение каждого элемента последовательности не превышает 1000. количество элементов последовательности не превышает 10000. напишите программу для решения поставленной , которая будет эффективна как по времени, так и по памяти (или хотя бы по одной из этих характеристик). программа считается эффективной по времени, если время работы программы пропорционально количеству элементов последовательности n, т.е. при увеличении n в k раз время работы программы должно увеличиваться не более чем в k раз. программа считается эффективной по памяти, если размер памяти, использованной в программе для хранения данных, не зависит от числа n и не превышает 1 килобайта. входные данные представлены следующим образом. в первой строке задаётся число n — общее количество элементов последовательности. гарантируется, что n > 8. в каждой из следующих n строк задаётся одно неотрицательное целое число – очередной элемент последовательности. пример входных данных: 10 100 45 55 245 35 25 10 10 10 26 программа должна вывести одно число — описанное в условии произведение. пример выходных данных для выше примера входных данных: 2600. решение: var n,max,max2,i,a: integer; begin readln(n); max: =8; max2: =0; for i: =1 to n do begin readln(a); if a> max then if max-a> =8 then begin max2: =max; max: =a end else max: =a else if (max-a> =8)and(a> max2) then max2: =a; end; writeln(max*max2); end.