данна16
21.01.2021 09:24

Напишите программу в pascal abc, которая в последовательности целых чисел определяет количество чисел, кратных 5 или 9. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число: количество чисел, кратных 5 или 9. входные данные: 15 91 90 0 выходные данные: 2

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Var a,k:integer;
begin
k:=0;
readln(a);
while a<>0 do
 begin
 if (abs(a) mod 5=0)or(abs(a) mod 9=0)
  then k:=k+1;
 readln(a);
 end;
writeln('k = ',k);
end.

Пример:
15
91
90
0
k = 2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота