Янчик312
23.03.2020 23:26

Написать программу умножения двух чисел по методу аль-хорезми с++ 11 13 5 26 2 52 (вычёркиваем) 1 104 143 (ответ)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tunekoff228
26.04.2020 14:30
#include<iostream>
using namespace std;

int main()
{
    int A,B,C = 0;
    cin >> A >> B;
    
    while(A > 1)
    {
        if (A % 2 != 0) C+=B;
        B*=2;
        A/=2;
    }
    cout << (C+=B);
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота