kolyanovak7
08.03.2020 13:05

На языке программирования паскаль напишите программу, которая: 1) в последовательности чисел находит количество чисел, кратных 3. 2) в последовательности чисел находит максимальное четное число, оканчивающееся на 4.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MarinaSc1
03.08.2020 12:47
1)
program kr3sum;
var i,s.h:integer;
begin 
read(k) //кол чисел 
for i:=1 to k do begin 
read(h) //число для действий 
if h mod 3 = 0 then begin s:=s+1;
end;
writeln(s);
end.
2)
program jeje; 
var k,i,m,s,h:integer;
begin m:=0;
read(k);//кол-во чисел
for i:=1 to k do begin
readln(h);
if h mod 10 = 4 then begin s:=h;
            if s > m then m:=s                       
   end;
end;
write(m);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота