Анастасия105
10.12.2021 13:01

Написать программу при регулярныхвыражений, которая проверяет, является ли введенная с клавиатуры строка целым числом.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
malinka149
06.10.2020 06:33
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString;
  var s1:=s.MatchValue('[\+-]?\d+');
  if s1=s then Writeln('Целое число')
  else Writeln('Не целое число')
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота