nastyaswan1405
11.12.2020 14:38

Напишите программу на языке программирования pascal. дано натуральное число n. если число большое нуля, то вывести это число, увеличенное в 7 раз, а иначе вывести квадрат этого числа.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Анестнйшен
06.10.2020 05:36
1. Современное решение

PascalABC.NET 3.2, сборка 1427 от 24.04.2017
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  Writeln(n>0?n*7:n*n)
end.

2. Школьное решение в стиле ТурбоПаскаль 1983г.

var
  n:integer;
begin
  Write('n=');
  Read(n);
  if n>0 then n:=7*n
  else n:=n*n;
  Writeln(n)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота