Паскаль. составить программу для решения следующей : даны числа a, b - целые (< > 0). сократить дробь a/b. сначала найти нод этих двух чисел. затем знаменатель и числитель разделить на нод.
// PascalABC.NET 3.2, сборка 1427 от 24.04.2017 // Внимание! Если программа не работает, обновите версию!
begin var p,q:integer; Write('Введите числитель и знаменатель: '); Read(p,q); var a:=abs(p); var b:=abs(q); while b<>0 do begin a:=a mod b; Swap(a,b) end; p:=p div a; q:=q div a; Writeln('Результат: ',p,'/',q) end.
Пример Введите числитель и знаменатель: 1440 16200 Результат: 4/45
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку