ovosh228322
03.01.2022 08:13

Написать программу в паскале. дан массив размера n. 1. найти количество участков к, на которых его элементы монотонно возрастают.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
динакоровина
06.10.2020 04:19
Const n=20;
var a:array[1..n] of integer;
i,k,m:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(51);
 write(a[i]:3);
 end;
writeln;
k:=0; m:=0;
for i:=1 to n-1 do
 begin
 if a[i+1]>a[i] then begin m:=m+1; end
 else begin if m>0 then k:=k+1; m:=0; end;
 end;
if m>0 then k:=k+1;
writeln('k = ',k);
end.

Пример:
Массив A:
  7 30 22  0 17  4  2 32 39 26 23 41  1 38 47 21 38 31 43  7
k = 7
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота