Юлик334
14.06.2020 05:40

Решать на pascal abc.net версия 3.2 сборка 1417. написать программу, которая выполняет сравнение многоразрядных десятичных целых чисел. то-есть вывести > если первое число больше второго; вывести < если второе число больше первого; вывести = если числа равны.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
anninor53
06.10.2020 04:00
Var a,b:uint64;
Begin
Write('Введите два целых числа: ');ReadLn(a,b);
if a > b then Write(a,' > ',b)
else if a < b then Write(a,' < ',b)
     else Write(a,' = ',b)
End.
0,0(0 оценок)
Ответ:
aruzhaan2003
06.10.2020 04:00
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017

begin
  var a:=ReadlnString('1-е число:').ToBigInteger;
  var b:=ReadlnString('2-е число:').ToBigInteger;
  if a>b then Writeln('>')
  else
    if a=b then Writeln('=')
    else Writeln('<')
end.

Пример
1-е число: 45685695606778795409839437392759354
2-е число: 8643603434233452532223423423525
>

Замечание: разрядность чисел - произвольная.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота