danayakim
28.11.2022 02:50

Нужно написать программу на языке с++: дана последовательность целых чисел, за которой следует 0. найти разность минимального и максимального элементов в этой последовательности.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Snupian
06.10.2020 03:35
#include<iostream>
using namespace std;
int main()
{
    int A;
    cin >> A;
    int Min = A;
    int Max = A;
    while(A)
    {
        cin >> A;
        if (Max < A && A!=0) Max = A;
        if (Min > A && A!=0) Min = A;
    }
    cout <<"Min = "<<Min<<"\n";
    cout <<"Max = "<<Max<<"\n";
    cout <<"Min - Max = "<<Min-Max<<"\n";
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота