rudnevskaya2004
26.02.2021 00:14

Написать программу.(информатика) 1)элементы заданного массива x = (x1 , x2, ) переупорядочите следующим образом: x = (xn , xn-1 , x1 ).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ник10910
06.10.2020 03:30
Var i,n,k: integer;
    a: array[1..100] of integer;
begin
  write('n = ');  readln(n);
  randomize;
  writeln('исходный массив:');
  for i:=1 to n do
  begin
    a[i]:=random(100)-50;
    write(a[i],' ');
  end;
  writeln;
  writeln('новый массив:');
  for i:=1 to n div 2 do
  begin
    k:=a[i];
    a[i]:=a[n-i+1];
    a[n-i+1]:=k;
  end;
  for i:=1 to n do write(a[i],' ');
end.

n = 10
исходный массив:
45 -29 -25 12 -38 5 15 16 47 -36
новый массив:
-36 47 16 15 5 -38 12 -25 -29 45
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота