oksanademyanov
15.05.2022 09:52

Составить программу в паскале используя функции или процедуры , которая будет вычеслять площадь треугольника по трем сторонам. в программе выполнить проверку существования треугольника

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lol09890
31.08.2020 23:28
Function S(a,b,c:real):real;
Var
   p:real;
Begin
p:=(a+b+c)/2;
result:=Sqrt(p*(p-a)*(p-b)*(p-c))
End;

Var
   a,b,c:real;
Begin
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
if (a<b+c)and(b<c+a)and(c<a+b) then WriteLn('S = ',S(a,b,c))
else WriteLn('Треугольник не существует')
End.

Пример:
a = 3
b = 4
c = 5
S = 6
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота