gaydukov130
15.05.2022 09:52

дан массив из 20 элементов.найти кол-во элементов оканчивающихся на 4. программа паскаль. написать программу

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
linapetrenko
20.08.2020 17:55
Var i, k: integer;
var arr: array[0..19] of integer;

begin 
  for i := 0 to 19 do   
    read(arr[i]);  
  for i := 0 to 19 do 
    if arr[i] mod 10 = 4 then     
      k := k + 1;       
  writeln(k);
end.
0,0(0 оценок)
Ответ:
Фрао
20.08.2020 17:55
Const
   N = 20;
Var
   A:array[1..N] of integer;
   i,k:integer;
Begin
Randomize;
k:=0;
For i:= 1 to N do
    Begin
    A[i]:=random(201)-100;
    Write(A[i],' ');
    if Abs(A[i]) mod 10 = 4 then k:=k+1
    End;
WriteLn;
WriteLn('k = ',k);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота