imhopro
23.02.2021 03:41

С++

написать программу с подробными комментариями , которая

1. обьявляет переменную cord типа int , значение которой вводит пользователь

2. делает проверку ввода : если вводится символ или несколько символов (кроме ' . '), программа очищает поток ,выводит в консоль сообщение об ошибке и кидает на этап ввода переменной cord. если вводят ' . ' ,то программа выводит сообщение о том , что введена точка, если введено число, то программа просто заканчивается

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
raxmatullin174
24.05.2022 05:33
Const
handsfree = true;

type
mas100_100 = array[1..100, 1..100] of integer;

var
a1, a2, a3: mas100_100;
i, j, m, n: integer;

procedure InitializeMatrix(var a: mas100_100; m, n: integer);
var
i, j: integer;
begin
writeln('Данные матрицы');
for i := 1 to m do 
begin
for j := 1 to n do
if handsfree then begin
a[i, j] := random(30);
write(a[i, j]:2, ' ')
end
else
read(a[i, j]);
writeln;
end;
end;

begin
writeln('Введите размер матриц');
readln(m, n);

InitializeMatrix(a1, m, n);
InitializeMatrix(a2, m, n);

writeln('Вывод результата');
for i := 1 to m do 
begin
for j := 1 to n do 
begin
a3[i, j] := a1[i, j] * a2[m + 1 - i, n + 1 - j];
write(a3[i, j], ' ');
end;
writeln;
end;

readln;
end.
0,0(0 оценок)
Ответ:
SharkiLoge
07.03.2021 07:45
Uses crt;
var ksl,ksm:longint;
a:array of integer; 
i,sred,k:integer;   
f:Text;
s:string;
BEGIN
clrscr;    
Assign(f,'f1.txt');
Reset(f); //из файла  
while not eof(f) do  
  begin
    readln(f,s); 
    ksm:=ksm+length(s); //считаем все символы 
  end; 
writeln(ksm);  
Reset(f);  for i:=1 to ksm do      
   begin   
       if (s[i]=' ') then            
       ksl:=ksl+1;//считаем все слова   
   end; 
writeln(ksl); 
Reset(f); //из файла
setlength(a,ksl+1);  
for i:=1 to ksl do 
     begin   
        read(f,a[i]); 
     end;
Close(f);
For i:=1 to ksl do   
     begin   
        If (a[i]=0) then a[i]:=a[1]+a[ksl]; // '' все нулевые компоненты значением суммы первой и последней компонент файла''
       if (a[i]>0) then
              begin   
                   sred:=sred+a[i]; // ''найти среднее арифметическое положительных компонент''   
                   inc(k); 
              end;       
       if (a[i]<0)then a[i]:=a[i]- ABS( a[1]+a[ksl] );  // ''все отрицательные компоненты уменьшить на значение суммы''   
     end;
Rewrite(f); //в фаил
for i:=1 to ksl do 
    begin       
       write(f,a[i],' ');     
    end;
Close(f); 
Writeln(' sred= ',sred/10:0:1);
END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота