ШкОлА1337228
03.04.2022 05:05

1. составить программу вычисления 2-ой, 3-ей и 4-ой степени числа a и возвращения этих степеней в переменных b, c, d. разработать процедуру, для которой a — это входной параметр; b, c, d — это выходные параметры. выполнить вычисления для 10-ти разных чисел. результаты выдать на экран в программе в виде таблицы: a b c d нужна в паскале(нужна программа)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
olyazyuzko2017
09.09.2020 10:44
Procedure ABCD(Const A:real; Var B,C,D:real);
Begin
B:=A*A;
C:=B*A;
D:=C*A;
End;
Var
   A,B,C,D:real;
Begin
Write('A = ');ReadLn(A);
ABCD(A,B,C,D);
WriteLn(A,' ',B,' ',C,' ',D);
End.

Пример вычислений для 10-ти разных чисел:

A = 1
1 1 1 1

A = 2
2 4 8 16

A = 3
3 9 27 81

A = -10
-10 100 -1000 10000

A = 3.141592
3.141592 9.869600294464 31.0062573282858 97.4090099724839

A = 111
111 12321 1367631 151807041

A = 6.66
6.66 44.3556 295.408296 1967.41925136

A = -2.718121812
-2.718121812 7.38818618487016 -20.0819900202127 54.5852951023063

A = 789456123
789456123 6.23240970142191E+17 4.92021399983213E+26 3.8842930686378E+35

A = 123456789
123456789 1.52415787501905E+16 1.88167637178915E+24 2.32305722798259E+32
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота