путникспутник
23.06.2022 09:30

Pascalabc нужно написать программу с "if" вот сама : даны два угла теугольника (в градусах) (которые вводит пользователь). определить, существует ли такой треугольник. если да, то будет ли он прямоугольным?

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ekkaterrinna2003
20.08.2020 17:22
Var
    a, b: integer;

begin
    readln(a, b);
    if a + b >= 180 then
        writeln('Такой треугольник не может существовать')
    else if (a = 90) or (b = 90) or (a + b = 90) then
        writeln('Это прямоугольный треугольник')
    else
        writeln('Это треугольник')
end.

если надо записать в стиле PascalABC.Net, скажи допишу
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота