777ppp777
30.06.2021 18:00

Составить программу для нахождения нод десяти двухзначных чисел. паскаль.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
юрий113
03.08.2020 10:49
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

function gcd(a,b:integer):integer; // НОД
begin
  while b<>0 do begin a:=a mod b; Swap(a,b) end;
  Result:=a
end;

begin
  var a:=ReadArrInteger('Введите 10 натуральных двухзначных чисел:',10);
  var g:=gcd(a[0],a[1]);
  for var i:=2 to 9 do g:=gcd(g,a[i]);
  Writeln('НОД=',g)
end.

Пример
Введите 10 натуральных двухзначных чисел: 38 42 56 82 96 32 18 40 58 90
НОД=2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота