karakushan
08.11.2021 07:02

Написать программу, которая по трем заданным углам треугольника определяет и выдаёт на экран вид этого треугольника на pascal

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kokgggg
06.10.2020 00:27
Var a,b,c: integer;
begin
write('a= ');
readln(a);
write('b= ');
readln(b);
write('c= ');
readln(c);
if a + b + c <> 180 then
 writeln('Треугольник не существует') else
if (a = 180) or (b = 180) or (c = 180) then
 writeln('Треугольник вырожденный') else
if (a = 90) or (b = 90) or (c = 90) then
 writeln('Треугольник прямоугольный') else
if (a > 90) or (b > 90) or (c > 90) then
 writeln('Треугольник тупоугольный')
else writeln('Треугольник остроугольный');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота