Войти
Регистрация
Спроси ai-bota
настёна20055
30.03.2022 14:17
С++ написать программу, которая по введённому пользователем названию месяца будет выдавать количество дней в этом месяце.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
olga180982
22.09.2020 23:18
Пользователь работал с каталогом с : \ \ сначала он поднялся на один уровень вверх потом спустился в каталог экзамен и после этого спустился в каталог кинематика укажите...
danilstal14
06.07.2022 18:34
98 ! с файловым вводом выводом в free pascal. ошибка exitcode = 2...
Cat2081
13.08.2022 08:31
Алфавит состоит из 64 символов. какое количество информации несёт один символ этого алфавита? 2. сообщение, записанное буквами из 128-символьного алфавита, занимает 2 страницы...
равиль7777777
12.04.2022 23:42
Сор 2 по иные за 1 четверть последними ...
ЯтвойДругг
05.12.2020 03:03
Составить блок схему (обязательно) и программу вычисления функции y=0,если x=0 =1, если x 0 Иначе - 1...
леньчайник
20.01.2023 06:15
Зачем человек использует роботов (отметь верное): потому, что роботы не могут спать потому, что роботы могут выполнять тяжелую работу для того, чтобы робот может следить...
Vitoriofedorov
20.01.2023 06:15
Создайте циклическую презентацию на любую тему,кроме скакалочка...
artemssh2
27.04.2021 06:41
Ребята умоляю проставлю 2❤️ и хорошую оценку кто . Не могу выполнить задание. Это язык программирования Phython Basic! Задача 4. Площадь треугольникаЧто нужно сделатьНапишите...
ttt123634
26.03.2023 04:29
Решить в Python Вычислить значения выражения 15x^2+8x-9 (переменная x должна вводится с клавиатуры)...
alinashelepova1
22.06.2021 11:27
Одномерный целочисленный массив содержит 50 элементов ,задаваемых с датчика случайных чисел в интервале от 1 до 200 .используя цикл с параметром (for) подсчитать сумму элементов...
Ответ:
optymus
06.10.2020 00:00
#include <iostream>
#include <map>
#include <string>
using namespace std;
int main()
{
string mon;
map<string, int> months = {
{"январь", 1},
{"февраль", 2},
{"март", 3},
{"апрель", 4},
{"май", 5},
{"июнь", 6},
{"июль", 7},
{"август", 8},
{"сентябрь", 9},
{"октябрь", 10},
{"ноябрь", 11},
{"декабрь", 12}
};
cout << "Введите название месяца строчными буквами: ";
cin >> mon;
switch (months[mon]) {
case 2:
cout << "28 дней";
break;
case 1:
case 3:
case 5:
case 7:
case 8:
case 10:
case 12:
cout << "31 день";
break;
case 4:
case 6:
case 9:
case 11:
cout << "30 дней";
break;
}
cout << endl;
return 0;
}
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота